Author Archives: admin

oacapture-1.1.0 released

It’s been a long time coming, but v1.1.0 is finally here. There are quite a few changes, though many of them won’t be visible to the casual observer. For instance, the build system has been made more robust and internal copies of libraries updated to fix a few problems on systems with older libraries. The more obvious bugfixes and enhancements include:

  • RPM and DEB format binary packages for Linux
  • Use the latest version of the ASI SDK (0.6.0504)
  • Support for PNG output
  • Enable building against Qt5
  • Increase usbfs memory available for ASI cameras
  • The default position of the controls is now to the right of the preview pane
  • FITS output is enabled for 8-bit RGB frames
  • TIFF format output should be allowed for colour cameras
  • 16-bit greyscale UVC cameras should be supported
  • A problem with the exposure time setting in the text file is fixed
  • A problem with slow exposures of over 999ms has been fixed
  • The “hide controls” option has been removed as the window splitter handle now supports this function

Remember on Linux that you need to add your user to the “users” group before many USB cameras will work. Linux users will also need to install the DEB/RPM files for libasicamera (which is a packaged version of the ASI SDK) and libuvc. These are also available on the downloads page.

My intention is to put the sources on Github shortly. If possible, please report issues on the Github issues tracker as it will enable me to keep track of things more easily.

oacapture 1.0.0 released

This is a little rushed as I want to get it out before taking a break, but it’s time for the 1.0.0 release. I think we’re at that point now. So, what’s changed?

The bad news is that things have become fairly hairy with the build tree, even compared with previous releases. This is partly to incorporate new libraries for cameras based on Touptek hardware and partly because a bleeding edge release of libdc1394 is required to support some of the newer Point Grey IIDC-over-USB cameras. The build works for me, but it might be really quite painful on other systems.

Changes include…

  • Implementation of a GPS-based camera control and timer mechanism to timestamp (FITS) files. This uses some bespoke hardware that hopefully I’ll be able to talk more about later, but the intention is to be able to accurately timestamp images for occultations
  • Allow sub-millisecond exposure times
  • ASI camera library update (to the May 2016 release)
  • Add support for Touptek cameras
  • Update support for newer ZWO cameras
  • Enable the ASI2 interface
  • Allow UtVideo codec to be disabled
  • Load the shared library for the Point Grey GigE cameras at runtime, so a single executable should work fine whether you have the library or not
  • Ditto with the Touptek cameras
  • Fix “directory not writable” error with FITS/TIFF files
  • Fix problem with 16-bit SER file format
  • Allow capture to MOV and TIFF files from raw colour if the output data is demosaicked

And there are a few other bugfixes too.

The ASI2 interface I’m not entirely happy with. It probably should still be considered experimental at this stage. Neither would I describe the Toupcam support as “complete” as there are one or two areas I’m not entirely happy about because the documentation isn’t 100% clear. I’m (still) waiting for a response from Touptek support on those. It’s pretty much there though.

Building releases is a slow process, so I’ve initially uploaded the OSX release and the sources. I’ll add binaries for Linux systems as I get them built. This may take a little while as the installation is getting rather more complex now.

oaCapture 0.9.0 release

Well, it’s been a very long time coming… Sometimes life has other plans.

Partly this is because I have been waiting, waiting and waiting some more for Apple to release an update for El Capitan which fixed some of the problems introduced by the re-write of the USB layer in OSX 10.11. The latest release (10.11.4) appears to have massively increased the stability of the USB layer. If you want to try El Capitan then you probably need to have patched to at least that release.

Otherwise, what have we got? The main reasons for releasing now are to include the latest ASI SDK with support for all the new cameras and to provide improved support for El Capitan which has been a problem until now. There are also various bugfixes, lots of tidying up, some development work which is not yet complete, an update to the included libusb code (required for support on El Capitan), improvements to TIFF and FITS handling. I believe the OSX binaries should once again run on all versions from Snow Leopard on.

Testing has now expanded to fill an inordinate amount of time compared to coding. I’m going to have to do something to change that. For this release I’ve dropped the 32-bit builds (though I can do these on demand if required). I’ve also dropped builds for older Linux releases (same applies). I need to do a little work to get a Raspbian build to complete as well, so no binaries are currently available for that. I don’t think it’s much work, so I can prioritise that if people are clamouring for it.

Going forward I think I’m going to arbitrarily designate a release as 1.0.0 fairly soon. At that point I’ll be looking to put all the code in a public repository, preferably with some sort of bug-tracker, and make a “release candidate” distribution before each major update so hopefully others can join in with the thrill of testing 🙂

oaCapture on El Capitan

There appear to be some problems with oaCapture on El Capitan. I’m still trying to run these to ground. I know this affects the ZWO cameras, but I haven’t tested any others yet. It looks as though Apple have fiddled with the USB layer a fair bit between Yosemite and El Capitan and code that works on all 64-bit systems from Snow Leopard to Yosemite is now broken 🙁

At the moment I’m afraid I don’t have an ETA for fixing this. Some workarounds for part of the problem have been added to libusb, but they don’t completely resolve the issues. I’m continuing to work on it.

oaCapture 0.8.0 release

Second release in a month! (By the skin of my teeth 🙂

That does mean there aren’t too many new features in this one. The main changes are partial support for the Celestron Neximage cameras and potentially Imaging Source USB2 CMOS cameras, support for the cooler controls in ZWO ASI cameras and support for Point Grey GigE cameras. There are also bugfixes for the ARM7 build, Point Grey IIDC cameras, the limit selection box not functioning intuitively on OSX and a few others.

I have tested the Neximage Burst C on Linux and OSX. On Linux it appears to work fine. On my (non-unibody) Mac Mini it appears to work fine on both Snow Leopard and Yosemite. However, on my 13″ 2013 Macbook Pro it appears to lock up the USB subsystem completely which requires a reboot to restore it regardless of which OSX release is used. I thought this was a hardware compatibility problem, but booting the MBP into Linux allows the camera to work happily, so it looks like some strange issue with OSX on my MBP. There do seem to be a number of reports of people experiencing hangs with USB devices on the 2013 13″ MBP, so it may just be my model. I would suggest however that if you’re going to give this camera a try on OSX, make sure all other applications are closed first and be prepared to have to turn off the power to recover the machine if it hangs.

The Burst M is untested but I believe it should work as well as the Burst C. The Neximage 5 may work with restricted functionality or may not work at all. Other Neximage cameras are not supported by this release.

The Imaging Source USB2 CMOS cameras (DFK22, DFK42, DFK72 and their mono counterparts) may work as the Neximage cameras are based on some of these models, with the same caveats for OSX.

ZWO cooler support is obviously not properly tested as the production cameras are not yet available.

At the moment Point Grey GigE cameras are supported using their Flycapture2 SDK. I can’t distribute this, so anyone wishing to use it will need to download and install the latest version themselves. You’ll then either need to build from source (the build system will find the libraries and use them if they’re present) or I can perhaps make binaries available that are linked against the necessary shared objects. I believe mono cameras should work, but colour cameras are not tested.

Feedback on which of these cameras work or don’t and particularly which Apple hardware the Celestron/Imaging Source cameras work on will be gratefully received.

Downloads from the page linked above.

oaCapture 0.7.0 release

“Famous last words”. Integrating support for the new ASI cameras turned out to be somewhat more tricky than I envisaged. In the end I managed to pin down a couple of bugs, one in oaCapture and one in the ZWO SDK and now we’ve got those fixed it looks like it works fairly well, so here it is.

Besides support for the new cameras the only other significant changes in this release are the addition of flags to put the gain and exposure values into the name for the capture files. Gain will be substituted for either “%G” or “%GAIN” and “%EXPMS” or “%x” will use the exposure time in milliseconds. “%EXPS” or “%X” does the same but in seconds.

See the links above for downloads.

Current plans for the next release include some sort of support for the Celestron Neximage cameras and the Imaging Source CMOS camera models as well as fixing a few niggly UI bugs.

oaCapture 0.6.0 release

Somewhat later than planned thanks to pressure of work and then holidays, 0.6.0 is finally out.

This is largely a bugfix release. A few niggles with Imaging Source cameras should now be resolved, in particular a problem with white balance handling with the colour FireWire models.

I’ve also upgraded the included ffmpeg library to the latest version. This builds more cleanly meaning I can exclude more bits that aren’t required and make the binaries smaller.

Downloads in the usual place.

Hopefully 0.7.0 shouldn’t be very long at all as I’ll just be focusing (Hah! See what I did there? 🙂 on support for the latest ZWO camera models for that.

oaCapture 0.5.0 release

After sitting completed for a couple of weeks whilst life decided it had rather different plans for my time, version 0.5.0 is now released.

Major changes for this release include:

  • Support for saving 8-bit greyscale and raw colour images as Windows DIB format AVI files
  • Addition of an “auto” option for the demosaic pattern, meaning the pattern reported by the camera driver will be used
  • Extend the colour masks available in libuvc to support the DFK21 (and probably other TIS colour CCD cameras)
  • A first attempt at a focus aid
  • A first attempt at support for the QHY5-II

The Windows DIB support is probably the most important new feature as it means AVI files from greyscale and raw colour cameras should import directly into AutoStakkert!2 and Registax. This option is enabled in the settings pane. Thanks to Chris Garry, author of PIPP, for allowing me to use his code to write these files.

The driver for the QHY5-II is, well, a bit ropey 🙁 Documentation is very sketchy and I’d not really describe it as approaching the desirable level of stability.

There are also some other changes, to allow longer exposures on the (original) QHY5 for example, as well as the usual stack of bugfixes.

The manual still needs updating. I’ll get that done as soon as possible.

oaCapture 0.4.0 release

Version 0.4.0 is now released. There are few functionality changes in this release, but the API for the camera library has been changed beyond recognition. This has resolved a number of awkward issues in the code as well as indirectly fixing some bugs and misfeatures. The camera library itself now runs to somewhere around 25,000 lines and very little remains untouched from previous releases so it’s hard to believe a few problems might have been introduced along the way, but I think it’s now in a far better state than it has ever been. I intended to do the same for the filter wheel API for this release, but tempus fugit and I thought I’d best get another release done.

As well as the API, other changes for this release include:

  • Building against the latest ASI SDK
  • Support for the ASI “high speed” option
  • An attempt to get colour TIS FireWire cameras to work in colour
  • Possible fixed support for the Microsoft Lifecam
  • Experimental support for ZWO cameras using the v2 SDK

Downloads from the downloads page as usual.

There are some issues with this release that I will attempt to correct at least some of for 0.5.0:

  1. When using the ASI174, switching into 2x binning and then out again appears to cause the camera to stop delivering images
  2. The “high speed” control for ASI cameras shows as unset initially, even if it is set
  3. The colour TIS FireWire support is being done completely blind. I do not have such a camera and I know the camera claims to deliver mono data when in fact it is raw colour. I could really use some feedback on this.
  4. The experimental v2 SDK code for ASI cameras is disabled and can only be enabled by manually editing the configuration file. I’ve tested with several ASI cameras and the only one I can get to work reliably is the ASI120MM-S.